System Requirements

Sketch 52.4 and above requires macOS High Sierra (10.13.4) or newer, and a working Internet connection, in order to be able to install the software and receive updates and upgrades.

If you are running an older version of Mac OS, please check our Updates page for links to download older versions.

If you want to update your version of Mac OS, in order to use the latest version of Sketch, follow the instructions on Apple’s website to upgrade your operating system.

If you’re working with more complex documents, involving multiple Pages and hundreds of Artboards, a powerful Mac with more RAM will definitely improve performance. If you’re not sure about compatibility you can download our 30 day free trial to test the performance before you purchase.

Last modified on Jul 18, 2018

Was this article useful?

Yes
No

We’re really sorry about that.
Please let us know what you were looking for:

If you need more help or you’d like to report a bug with this content, please contact support.

Thanks for your feedback.
An error occurred, please try again later.